Step1. Install Apache2 using the command:

apt-get install apache2-mpm-worker

Now you cand navigate from  your browser to http://your-ip to check if Apache2 is working (you should see the Apache2 default page with message:  It works).

Step2.  Install PHP5-FPM.

We will make PHP5 work in Apache2 through PHP-FPM and Apache2  mod_fastcgi module.
We need to install apache mod-fastcgi first:

apt-get install libapache2-mod-fastcgi php5

Now install php-fpm:

echo “deb stable all” >> /etc/apt/sources.list
echo “deb-src stable all” >> /etc/apt/sources.list
cat dotdeb.gpg |apt-key add -
apt-get update
apt-get install php5-fpm

Step3. Enable the  Apache2 modules: Continue Reading…

Using Dotdeb is very simple.

1. First add these two lines to your /etc/apt/sources.list file:

deb squeeze-php54 all
deb-src squeeze-php54 all

2. Now fetch the appropriate GnuPG key:

cat dotdeb.gpg | sudo apt-key add -

3.Install PHP 5.4: Continue Reading…

Page 1 of 11